Outlook Office 365 System Folder Names appear with 1

RSS Feeds1After an Office 365 migration I had noticed I had some duplicate folders in my Outlook. The duplicate folder appeared with a 1 next to the folder name, and what’s worse it was on the ‘System Folders’ like Junk Mail or RSS Feeds.

you might be forgiven for thinking, so what? well indeed, but it was annoying the hell out of me and this is my website, so there you go..

I tried numerous times to remove them, or delete them, and replace them with new folders. Of course none of this worked. Read more of this post

Lost a document, opened and saved from email

metro iconA client popped into our office on Friday with a query, they had worked on a document saved it, but now when they went back to open it, there was no trace of it anywhere. After the usual suggestions of ‘are you sure you saved it?’ ‘have you searched for it?’ ‘are you sure you saved it?’ i asked him to bring his laptop over. Luckily he was based in the office next door so it was not a long trip.

Read more of this post

Outlook is losing my email?!? Event ID 9646 (Application Log)

iconRecently at a client of mine, we had an issue where one users Outlook would continually stop displaying new email. The inbox would show ‘last updated at..’ and would not move on from that time but, Outlook would correctly display ‘Connected’ in the bottom right corner. Read more of this post

Quick Fix: Outlook 2010 Sending from a second Exchange Mailbox

sbsstd

I have been battling this problem for some time now. It has been driving me to distraction it is fair to say.

Exchange

What i didn’t realise until now, is that i was actually battling two separate issues, once i realised that it made the solution clear.

The issue i was facing was that additional mailboxes were being automatically added to an Outlook profile. This was puzzling me because firstly, i didn’t know why it was happening, and secondly i OutlookLogowasn’t able to send from that second mailbox. I could manually type in the address in the From field, but i wanted to be able to choose it and have the signature change based on the account i was using.

So a lot, of research, lab work and questions later i think i found the answers, and the solution.

Issue 1. Exchange 2010 SP1 Full Mailbox Access

Are you running Exchange 2010 SP1 with clients running Outlook 2010 SP1?

If you are, and like me you have shared mailboxes, or generic mailboxes that other users access, you may be used to setting Full Mailbox access permission on those generic accounts.

Full Access

(You would then add them to Outlook through the properties of your Primary Mailbox, under More Settings, and Advanced)

With Exchange 2010 SP1 and Outlook 2010 SP1 having given full mailbox access to an account, you may have seen a that the account that you have full mailbox access to, has automatically added itself to your Outlook profile.

You may also notice, there is no way to remove it!

auto added

This behaviour is actually well documented, but one of the best explanations i found is here.

If you don’t want to bother reading that – and you should read it – basically using Exchange 2010 SP1 EMC, EMS to add Full Mailbox Access, now also sets an Attribute on the account – msExchDelegateListLink. This attribute says which other accounts have access to this mailbox.

Attribute

Outlook 2010 SP1 will look for that key now and anyone that matches, will be auto added. Quite straight forward when you know what is happening.

So that is the first part of the mystery solved.

The solution to stop this happening is easy, remove that attribute. You can either do it through ADSIEdit, or by Adding Full Mailbox Access with a script instead of using the EMC/EMS. again ill point you back to this blog for the solution.

Assuming you have now removed that attribute, you can go ahead and add the second mailbox the traditional way.

 

Issue 2. Outlook 2010 Send from Multiple Exchange Mailboxes

But wait – once you have done this, you still cannot select it as an account to send from?

send

At this point i really started to get frustrated. I was wrongly blaming Exchange 2010 SP1 for this weird behaviour and missing the clue right under my nose.

It seems that the ability to send from a second Exchange mailbox, when it is added in what i will call, the traditional manner, has been changed in Outlook 2010.

I’m running Outlook 2010 and have several exchange mailboxes open, i just had never noticed this behaviour. I’m also running Exchange 2007, and having been dealing with the issue outlined above, i never thought to look at my own Outlook.

The solution here seems to be very simple indeed.

Once you have removed the attribute, you still retain full access. That means you can add the second mailbox, as a totally separate account, and you wont be prompted to login to that mailbox, because your current credentials have permission to open it.

So to recap, first you need to make sure you remove the msExchDelegateListLink attribute from the second mailbox. Then just add that second mailbox as a second account. You will need to close Outlook down in order to do that, when adding the mailbox choose to ‘Manually Configure Server Settings..’

manually add

You will then see the mailbox as a second account.

second account

And you can choose to send from this account as well.

send from

I really hope this helps you, and saves you some time and energy!

%d bloggers like this: