Quick Fix : Clean-up Duplicate Remote Web Access Certificates

SSLI noticed this thread in the forum a while ago, and setup a Lab network to reproduce it. Sure enough after a few days, my local machine certificate store is full of duplicated certificates.

The issue only seems to affect Essentials 2016 and only if you are using the free remotewebaccess.com certificates.

The issue is also discussed here on the MCB Systems blog.

Unfortunately for me work took over and i was not able to spend any more time on it, and with responses from Microsoft for any Essentials related issue being, shall we say, pedestrian, i wont be holding out any hope of a fix soon.

That doesn’t mean I can’t use it as an excuse to do some PowerShell though, which is about the only thing keeping my attention in the IT world these days.

So, run this in PowerShell in an elevated window, use the parameter ‘AutoClean’ as ‘Yes’ to automatically remove all the duplicates, and use the parameter ‘AddTask’ to have it setup a scheduled task to do this every day for you at 4am.

Duplicate Cert

On my LAB system, the duplicate certificates was the only issue, the new certificate had been installed correctly to IIS, and to RRAS for VPN Connections.

About Robert Pearman
Robert Pearman is a UK based Small Business Server enthusiast. He has been working within the SMB IT Industry for what feels like forever. Robert likes Piña colada and taking walks in the rain, on occasion he also enjoys writing about Small Business Technology like Windows Server Essentials or more recently writing PowerShell Scripts. If you're in trouble, and you can find him, maybe you can ask him a question.

5 Responses to Quick Fix : Clean-up Duplicate Remote Web Access Certificates

  1. Thanks Robert, that the next step I was working on with my new 2016 Essentials Server setting up the RWA. I’ll be sure to implement this.

  2. miles267 says:

    Is it possible to do an in-place upgrade from WSE12R2 to WSE16? I’m still running WSE12R2 have everything configured and working, including DirectAccess.

  3. Hi

    This problem also affect Essentials 2012R2.
    Is there a way to make the script work on 2012R2?

Leave a reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: