Have you tried turning it off and on again?

Saturday morning, i am not relaxing with a nice lie in – no I’m vpn’d into my customer site trying to resolve the issue from yesterday – some consolation I’m sitting in bed in my boxers :I too much information?

A quick check on all the logs – no issues reported, and a successful backup. A good way to start. I run the Exchange BPA – with a health check scan, and that doesn’t report anything critical so i feel like i am ok to do a much needed reboot.

Twenty minutes later I’m back in, a quick scan through event viewer – nope it still looks ok. Let’s try installing this MSA.

Log in to the console, add an exchange server, accepting the defaults – with one exception I’m not using the EUQ integration this time, let’s stick with good old Outlook junk mail folder.

Install in progress… usually a time to sit back and relax (yeah right) and it ‘looks’ like its doing more than it did before but you can never be sure as the descriptions on the progress indicator are not always that helpful. Validating install….. ohhh not again…

Nope that’s right, not again. A few minutes of Validating seem to do the trick as i am greeted by the most glorious site i have seen this early on a weekend for quite some time –

Starting Messaging Security Agent.

And a few minutes later….

I had to read it a few times just to be sure – and i swear one time i read it it did actually say something different.

Success. We have Success.

I quickly download the two patches for WFBS 5.1 from Trends website, and install them.

A little check over of all the settings and i am happy to open up inbound email again.

Let’s monitor the Real Time Scanning for the inevitable deluge of spam that’s heading my way.

hmmmmmmmmmmmmmm nothing coming in, lets reply to a test message i sent out earlier.

Yep it’s appeared in the RTS but not in the mailbox. It isn’t in the Message Tracking Logs either.

Back in my own Outlook Web Access i see the message has been rejected :

#5.7.1 SMTP; 550 5.7.1 Sender ID (PRA) Not Permitted> #SMTP#

This i know is a Sender ID bug with exchange 2003 – something to do with how exchange handles SPF records when email is sent via a smart host – the fix escapes me for the moment, after all it is still early. So i opt for disabling SenderID for the time being, happy that mail is flowing at least.

All in all not a bad result. The moral of this story then? I was going to say – if it isn’t broke, don’t fix it. But of course in this instance it was sort of broke, so I’m not sure it counts. But that is a good moral anyway so we’ll stick with that.

I will shortly be up and about – shopping no doubt – but it doesn’t matter, nothing can bring me down after this and the fantastic drubbing i dished out last night on Fifa (5-1), i think it’s going to be a good day.

With all the excitement i almost forgot to say why i had started a blog. Well  i don’t know really – it is something i have been interested in doing for a while, but i never really thought i had much to say.

And to be fair i probably still don’t.

Well a few days ago i was asked to be an author for the excellent www.smallbizserver.net site by the site owner Mariette Knapp, a Small Business Server MVP. I have written and published one article already which you can look at here : How to use Small Business Server 2003 Health Monitor to Alert you to Full Mailboxes

Ill be publishing more articles as time goes on hopefully, and will be putting sneak previews on my blog.

My next article will be about how to publish Small Business Server 2008 using ISA Server 2006.

Have a good weekend!

About Robert Pearman
Robert Pearman is a UK based Small Business Server enthusiast. He has been working within the SMB IT Industry for what feels like forever. Robert likes Piña colada and taking walks in the rain, on occasion he also enjoys writing about Small Business Technology like Windows Server Essentials or more recently writing PowerShell Scripts. If you're in trouble, and you can find him, maybe you can ask him a question.

Leave a reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: